Not logged in. · Lost password · Registration disabled
Forum: Overview Bugs / Fehler RSS
IIS: Getting [HTTP/1.1 405 Method not allowed] error :( Help! - nofix
Getting Error [HTTP/1.1 405 Method not allowed] after "Subscribing to Posts"
chrisemersonnc (Guest) #1
No profile available.
Link to this post
Subject: IIS: Getting [HTTP/1.1 405 Method not allowed] error :( Help! - nofix
I've searched the forums and this discussion - so far no one else seems to have this problem.

- Post_Notification was successfully Activated
- Post_Notification was successfully added to my META links
- Post_Notification can successfully send a TEST mail
- Post_Notification does show the "Subscribe to Posts" form
- ...however when the user enters their email and clicks SUBMIT, they get the error [HTTP/1.1 405 Method not allowed].

Please help!
This post was edited on 2007-10-21, 14:13 by Morty.
chrisemersonnc (Guest) #2
No profile available.
Link to this post
Subject: (cont)
BTW - Here's my system info:

- Windows 2000 Server
- IIS 5.x
- PHP 5.x
- MySQL 5.x
- Wordpress 2.3
Morty (Administrator) #3
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
Uhfz. I'm afraid I need an error message. Maybe something in a log file.
I also think I remember that there was some kind of problem with IIS and sending mails. You might want to have a quick google or look whether there is anything in the wordpress forums about that.
chrisemersonnc (Guest) #4
No profile available.
Link to this post
Subject: RE:
Thanks Morty. I actually have googled quite a bit.

Post_Notification actually CAN send email - the "TEST" function on the OPTIONS page works great! It's just that when a user clicks on the Widget link to actually SUBSCRIBE, hitting the SUBMIT button on that page results in the 405 error.

My PHP error log doesn't have anything in it either. :(
Morty (Administrator) #5
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
Hmm that's odd. Can you give me a link - if you want mail to pn@xn--strbe-mva.de .
chrisemersonnc (Guest) #6
No profile available.
Link to this post
In reply to post #4
Subject: RE
deciphering email link encryption...

fake@hotmail.com
chrisemersonnc (Guest) #7
No profile available.
Link to this post
Subject: RE
I sent you an email - but not sure I sent to the right address yet since I wasn't sure what to 'strip' from that address (if anything?).
Morty (Administrator) #8
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
I'd say your server does not support http-post. I changed the search form from get to post and got the same error. WP does support searching using post.
chrisemersonnc (Guest) #9
No profile available.
Link to this post
Subject: RE:
Hrmm. I have the PHP ISAPI setup in IIS for "all verbs" but I'll try specifying them manually (POST, GET, etc) and hope that works? I'll come back w/an update soon.

Thanks Morty - I appreciate your help very much.
chrisemersonnc (Guest) #10
No profile available.
Link to this post
Subject: RE:
Well..

I tried changing "All Verbs" on php5isapi.dll in IIS to a specific list ["GET,POST,HEAD"] but that didn't fix it.  I even tried going back to PHP4 but same problems keeps happening.

I have a slight suspiscion that it might be happening because of how WPress uses "Permalinks" (i.e. how there's not always a "PAGE" name in the URL (?)) - but that's just a theory.  Weirdest thing still to me is that the "TEST" email *does* work from my [WPress >> Options >> Post_Notification] management page. How can that page send emails but the actual Subscribe page not work?

Anyhow, if you have any other ideas please let me know! I really need an addon like this for my blog.

Thanks again

- Chris
Morty (Administrator) #11
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
You get a subscription mail, too. Looks like the Post handler runs the PHP script and has some kind of problem to send the data back to the user. But that is only a guess. Especially as the settings use Post, too. So it might as well be something WP does when, receiving a Post.
Unfortunately I can't help you with IIS. I already set up an Apache and a Sambar server and they both worked out of the box. I tried IIS once, but removed it after a short while, being fed up, because IMO it was much to complicated to add a user. :-/
chrisemersonnc (Guest) #12
No profile available.
Link to this post
Subject: RE:
Thanks again for trying Morty.

Since I can't get Post_Notification working, I don't suppose you know of any alternative "notification/subscription" plugins for WordPress? Just thought I'd ask. :)

Take care man,

- Chris
Morty (Administrator) #13
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
There's Subscribe2. IMHO not as powerfull, but simpler and probably works. ;-)
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum