Not logged in. · Lost password · Registration disabled
Forum: Overview Bugs / Fehler RSS
email not sent out
jotrys #1
Member since Jun 2007 · 18 posts
Group memberships: Mitglieder
Show profile · Link to this post
Subject: email not sent out
The Post Notification email is not sent out after a post has been posted.

Situation:
a) email were being sent out after a post was published
b) I changed the PN setting "Copy complete post in to the mail" from "The excerpt" to "No"
c) Now on publishing a post, no email is sent out
Expected:
an email sent out (without content)

More info:
-Version used: 1.1.5
- No error messages in the site error log
- On my test blog, with the same settings, the email is sent correctly

Do you need any other information?

thanks, jotrys
Morty (Administrator) #2
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
It's really hard to say, waht the reason is. Is the post listed on the info-page?
If not there are three possebilities:
  • It didn't get queued, e.g. because auf the settings. (You can override them, writing a post.)
  • It didn't get sent out. Some server-problem.
  • It ended up in the Spam-filter.
jotrys #3
Member since Jun 2007 · 18 posts
Group memberships: Mitglieder
Show profile · Link to this post
Hi Morty,

Replying to your different options:
Is the post listed on the info-page?
--> No, not listed.
If not there are three possebilities:
    * It didn't get queued, e.g. because auf the settings. (You can override them, writing a post.)
    ---> Not sure what you mean here. Do I write a new post, or do I publish the post again?
    * It didn't get sent out. Some server-problem.
    ---> Can not be a server problem since the test blog on the same server sends out email.
    * It ended up in the Spam-filter.
    ---> Not this either, since the test blog sends out an email.

Can it be that the setting "Number of mails to be sent in a burst" is too large since it is set at 20? Should I set this to 5?

cheers,
jotrys
Morty (Administrator) #4
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
  • Is the post listed on the info-page?
---> No, not listed.
  • This means it either didn't get queued or there is some server-problem. You can requeue the Mail in the Newsletter-box when you edit the Post and save it. The Box will be named Post Notification in the next version.


  • It didn't get queued, e.g. because auf the settings. (You can override them, writing a post.)
---> Not sure what you mean here. Do I write a new post, or do I publish the post again?
  • You can change the settings, whether a post is sent by default or not and you can override the setting when writing a post.


  • It didn't get sent out. Some server-problem.
---> Can not be a server problem since the test blog on the same server sends out email.
  • How many mails are on your subscription list? It might be, that your host has some limit how many mails you may send within an hour.


--->Can it be that the setting "Number of mails to be sent in a burst" is too large since it is set at 20? Should I set this to 5?
  • Very unlikely. The only thing that can happen is, that you Blog is blocked for a while or if the server terminates the script, that someone get's two mails.
jotrys #5
Member since Jun 2007 · 18 posts
Group memberships: Mitglieder
Show profile · Link to this post
Thanks for that Morty.


Quote by Morty:
  • Is the post listed on the info-page?
---> No, not listed.
  • This means it either didn't get queued or there is some server-problem. You can requeue the Mail in the Newsletter-box when you edit the Post and save it. The Box will be named Post Notification in the next version.

I am using Post Notification 1.1.5.

I guess the requeue you mention is in a new version of Post Notification?
Morty (Administrator) #6
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
You can just set send to yes, then it is sent again.
jotrys #7
Member since Jun 2007 · 18 posts
Group memberships: Mitglieder
Show profile · Link to this post
Well, I am able to generate another post notification by:
- Selecting yes for the "Send notification when publishing?" of the post
- then saving the post.
After this a post notification is sent.

OK! Great.

Now I have done this for my test blog. I will repeat it for my LIVE blog.
Thanks Morty.

And yes, the name change of the Newsletter-box to Post Notification is a good one.

By the way, am I missing Post Notification user documentation, since I was not aware of this resend functionality. Have not come across it.

cheers,
jotrys
Morty (Administrator) #8
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
There is a lack of documentation. In 1.2 it got a bit better. I'll try to improve it.
jotrys #9
Member since Jun 2007 · 18 posts
Group memberships: Mitglieder
Show profile · Link to this post
Using the re-queue functionality works well as a workaround.

But email notifications are still not sent after a post is published.
As the blog where this occurs is LIVE, my testing possibilities on that blog are limited.
The strange thing is that post notification works perfectly on my test blog which has exactly the SAME settings as my LIVE blog. (which is also on the same server).

I have upgraded to version 1.1.7 (both test blog and LIVE blog), but post notification emails are still not automatically sent on the LIVE blog. (Test blog works correctly.)

To provide you with extra info, the following are the Post Notification settings (both test and live):
--- --- ---
Type of header line break:                  \n    
Copy complete post in to the mail:       No    
Read-more-text:    
Send normal posts by default:             Yes    
Send private posts by default:            No
Send pages by default:                      No
Profile:                                            en_US
Template:                                       email_template.txt
Subject:                                        @@blogname: @@title
Sender-Name:                                 @@blogname
Number of mails to be sent in a burst:    20 seconds
Pause between transmission.              10 seconds
Nervous finger wait                           10 seconds
Number of Captcha-chars.                  0
--- --- ---

Any way forward on this? Do you need extra info?
Maybe a way I could perform tests on a LIVE blog?

cheers,
jotrys
Morty (Administrator) #10
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
It seems very odd to me, that the mail isn't sent out at all. (I just fixed a problem with mails being sent out several times on NFS.) Did the mail get queued? Set the nervous finger to 300 or so. That way you can check whether the Post is in the queue. If it doesn't show up in the queue after posting I have to find out why this happens (Might be some strange DB-Caching-thingy). If it does show up, it's almost certainly sent out, but may get lost somewhere between php an your mail server. You might want to give http://wordpress.org/extend/plugins/wp-mail-smtp/ a try. It enables you to use smtp instead of mail(), which is known to be a bit buggy.
jotrys #11
Member since Jun 2007 · 18 posts
Group memberships: Mitglieder
Show profile · Link to this post
Notification E-mails are sent out correctly again.

particulars:
After I made a post (as Admin) the notification emails are being sent out correctly again.
Strange as to why it is OK now. I do not understand.

Let's consider the problem solved, and I will raise a new bug report if it occurs again.

cheers,
jotrys
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum