Not logged in. · Lost password · Registration disabled
Forum: Overview Bugs / Fehler RSS
bug with xlanguage
only sending in my own language
drakkk #1
Member since Dec 2009 · 5 posts
Group memberships: Mitglieder
Show profile · Link to this post
Subject: bug with xlanguage
First, thanks you very much for this plugin which is exactly what i was looking for !

I'm posting here because i have a problem using it :

I use the plugin xlanguage with three languages : FR/EN/ES. I configured your plugin (in email_template.html) to add the three languages links after the post content. But, strangly, the plugin send an email only in MY language (fr) to every subscriber. I don’t know why..

<a href="@@permalink/lang/fr"><img style="border: 0pt none;" src="http://www.drakkk.fr/wp-content/flags/fr.png" alt="fr" width="18" height="12" /></a> <a href="@@permalink/lang/fr">Version Française</a><br />
<a href="@@permalink/lang/en"><img style="border: 0pt none;" src="http://www.drakkk.fr/wp-content/flags/us.png" alt="en" width="18" height="12" /></a> <a href="@@permalink/lang/en">English Version</a><br />
<a href="@@permalink/lang/es"><img style="border: 0pt none;" src="http://www.drakkk.fr/wp-content/flags/es.png" alt="es" width="18" height="12" /></a> <a href="@@permalink/lang/es">Versión español</a><br /><br />

The xlanguage plugin detect the following tags :
<span lang = "xx"> ... </span>
or in the url the http://site/post/lang/xx


On the configuration page i have : “Some plugins use filters to modify the content of an article. You can hope they do not modify one of your emails. Finding the right filter requires some testing.” I think this is where to configure that i don’t want the plugin to not detect the xlanguage tag. But there is no xlanguage tag..

Here is the list i have : wptexturize, convert_smilies, convert_chars, wpautop, prepend_attachment, generate_avatar_in_posts, post_notification_filter_content, visitors_map_post_map_filter, do_shortcode, GA_Filterthe_content, wpu_get_users, wp_dlm_parse_downloads, wp_dlm_parse_downloads_all, xmlgooglemaps_converter

I think i need your help. I can add you to the newsletter if you want, to test, or send you anything you need. I’m with the last version of wordpress.

Thank you very much in advance.
Hope you’ll be able to help me. Good night,
Arnaud
drakkk #2
Member since Dec 2009 · 5 posts
Group memberships: Mitglieder
Show profile · Link to this post
I forgot to say that the test works perfectly well (i receive all language links) and everything is perfect. It's only when i try to use the plugin to subscriber that it fails.

Thanks !

Edit : I checked all box in configuration page, just to test, but the same problem occured..
This post was edited on 2009-12-01, 18:54 by drakkk.
drakkk #3
Member since Dec 2009 · 5 posts
Group memberships: Mitglieder
Show profile · Link to this post
help :(
drakkk #4
Member since Dec 2009 · 5 posts
Group memberships: Mitglieder
Show profile · Link to this post
anyone ???
drakkk #5
Member since Dec 2009 · 5 posts
Group memberships: Mitglieder
Show profile · Link to this post
HELP PLEASE ! Just an answer.. Even if you don't know what i should do, just show me you saw my post !
Dirkus #6
Member since Apr 2009 · 6 posts
Group memberships: Mitglieder
Show profile · Link to this post
I did see your post, but I don't have any insight to share.  I am using Wordpress in English only and not with xlanguage support.

Dirkus
Morty (Administrator) #7
User title: Author
Member since Jun 2007 · 928 posts
Group memberships: Administratoren, Mitglieder
Show profile · Link to this post
PN is not compatible to any know multi-language-tool. The problem is, that the tool rewrites the page depending on language settings. Because PN relies on WP to render the email, the email is rendered in the language of the visitor. A solution could be, to tell xlanguage that no language is set before sending the mail. But I have no Idea how to do that. Unfortunately no time either. I'm happy that I'm acutally managing to work of my 3 month backlog. :-(
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum