Nicht angemeldet. · Kennwort vergessen · Registrierung deaktiviert
Forum: Übersicht Bugs / Fehler RSS
Emails not sending
plugin stopped working
WebWeaver #1
Benutzertitel: Web Weaver
Mitglied seit 10/2009 · 3 Beiträge · Wohnort: Nevada City, CA
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: Emails not sending
:-(

Without any action on my part, the plugin stopped sending emails today.  I upgraded the version, switched to database locking, debug mode on and off, activated WP Mail SMTP (but couldn't find the mail( call to change).

Test emails create data on test page, but emails are not going out to me or anybody on my list.

Please help!

-Catherine Scholz
http://catswebweave.com

My site is down at 11:30am PST - host is re-booting server.
My site is now back up at 12:09pm PST.'

Update: It's working now.  Very mysterious!
Dieser Beitrag wurde 3 mal verändert, zuletzt am 10.11.2009, 17:30 von WebWeaver.
CHuey #2
Mitglied seit 11/2009 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
I'm having the same problem over here, only that the emails are still in queue and nothing is sent.

Anyone has any idea? Changed to locking database...

- Huey -

Updates: It's working now, after deactivating another plugin. Strange thing is this plugin was already there for a while...
Dieser Beitrag wurde am 15.11.2009, 11:44 von CHuey verändert.
WebWeaver #3
Benutzertitel: Web Weaver
Mitglied seit 10/2009 · 3 Beiträge · Wohnort: Nevada City, CA
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: mysterious
It is still working for me - but I still don't know why it STOPPED working for a few days...
sassymonkey #4
Mitglied seit 11/2009 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Antwort auf Beitrag #2
Which plugin did you disable that fixed Post Notification?

I'm having a similar problem though it is intermittent: some emails are sent and others are not.

Interestingly, the status always shows that the Post message was sent. There is never anything stuck in a queue (so that I cannot set Debug on and refresh as other seem to be doing).

I set Locking to "Database" (though the same problems happened under "File"), "When to send" is set to "Shutdown" like it always has been (since I don't understand how "header" or "footer" represents a chronological event like Shutdown does), and tried setting "Debug" on and off.

Installing WP-Mail SMTP is not an option as it's only tested up to WP 2.7, plus this is a plugin bandage for one issue and I don't want yet another plugin to mess with the system.

The only other plugins that potentially accesses mail functions is the Add to Any: Share/Bookmark/Email Button and cforms plugins.

Testing is a problem since the "Test" admin form always works. It's just the new Posts that fail to be emailed sometimes. So if I deactivate plugins, I have to wait for my group to compose a new post. I certainly don't want to send a test message to all 250+ people on the list. I have yet to find info about what exactly the Debug mode does and how to utilize it.
sassymonkey #5
Mitglied seit 11/2009 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
To accurately test, I duplicated the entire public WP install where I'm having PN problems (srwestend.com) into a sub domain on the same server (staging.srwestend.com).

Unfortunately, I can't duplicate the problem. Every single new test post or resend of previous posts (that failed to be sent on the public version) always work in the staging version.  Very frustrating!

The public and staging versions both have almost identical configurations including WP version 2.8.5 and all plugins in the same versions too. The only major difference is I removed all of the public version's 285 subscribers in favor of a couple personal email addresses in the staging version: one with all categories selected and the other with three categories (to emulate public subscribers).

Any ideas why intermittent failure is occurring on the public version...?

So, for lack of a better solution, I supposed I can only install WP Mail SMTP on the public version and wait to see if PN sends on the next post the group submits.

NOTE: I tried installing Subscribe2, but its restrictions are too limiting. I don't know of another email list plugin unfortunately.
sassymonkey #6
Mitglied seit 11/2009 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Two issues just noticed: one with PN and unrelated issue with WP Mail SMTP.

1) Regardless of WP Mail SMTP installed or not, PN creates emails with two MIME-Version lines. When I look at the raw headers in a message created by PN, I can see this:

...
X-Mailer: PHPMailer (phpmailer.sourceforge.net) [version 2.0.4]
MIME-Version: 1.0
Reply-To: info@...
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
...

Supposedly, having two MIME-Version statements in an email can cause some mail servers to bounce the message. I'm not an expert, but I don't believe there's any reason to have two MIME-Version lines in a message header.

I notice that simply removing line 308 in the functions.php file of PN fixes the issue and only one MIME-Version line appears in the emails PN sends:

$header  = "MIME-Version: 1.0$hdr_nl";

__________

2) For WP Mail SMTP issue, as seen in the raw email header excerpt above, even with it installed I'm still showing emails being sent by PHPMailer and not via SMTP.

Is this a correct assumption?
CHuey #7
Mitglied seit 11/2009 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
The plugin that I disabled was a Social bookmarker. But then again, now it's not working again. Disabled other plugins, still not working. Arrgghhh...


- Huey -
CHuey #8
Mitglied seit 11/2009 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Now after about an hour of deactivating plungins, debug, including deactivating PN plugin itself, it worked...
Morty (Administrator) #9
Benutzertitel: Author
Mitglied seit 06/2007 · 928 Beiträge
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Odd. At least it's working.
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Gehe zu Forum