Nicht angemeldet. · Kennwort vergessen · Registrierung deaktiviert
Forum: Übersicht Bugs / Fehler RSS
action="" remains empty / Settings don't work
dolli #1
Mitglied seit 05/2009 · 1 Beitrag
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: action="" remains empty / Settings don't work
Hi!

I installed this plugin today on a fairly recent WP installation. I'm using Version 2.7.1 and the purpose of my blog is basically that whenever I post, they will receive an email with the update. The problem I'm having is that by using the widget the subscription form doesn't do anything. Upon reviewing the source code I find that the form simply doesn't point anywhere!

<div class="widget"><h3 class="widgettitle">Subscribe to Posts</h3><form id="newsletter" method="post" action="" ><p>Email:<br/> <input type="text" style="direction:ltr; text-aligh:left" name="addr" size="15" maxlength="50" value="thelovecube@gmail.com"/> <br/><input type="submit" name="submit" value="Submit" /></p></form></div>

action="" is simply an empty value, which is why it's not pulling through. Now I checked the settings page, and for whatever reason I can't access it. I also don't know what I'm supposed to do or what's supposed to go there.

Please save own Profiles in: /home/vhosts/ravengeek.com/httpdocs/art/wp-content/post_notification/
Otherwise they may be deleted using autoupdate.

What is meant with Profiles? What did I miss?

Help appreciated!
saharusa #2
Mitglied seit 05/2009 · 5 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Got the same problem over here with version 2.7.1

for this error:
Please save own Profiles in: /home/vhosts/ravengeek.com/httpdocs/art/wp-content/post_notification/
Otherwise they may be deleted using autoupdate.

it seems that you just need to create a folder name 'post_notification' under wp-content. (so upgrade won't delete your profile)
the error will be gone... but

after doing so, i get a blank settings page...
Morty (Administrator) #3
Benutzertitel: Author
Mitglied seit 06/2007 · 928 Beiträge
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
You are missing the last option in the PN-Settings. It must be the ID of the PN-subscription page or the URL of the PN-subscription page
saharusa #4
Mitglied seit 05/2009 · 5 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hi Morty,

the thing is there is no PN-Settings page.... the page is blank, I get title only: "Settings" with nothing else beside that...

Wordpress 2.7.1 and Wpmu 2.7.1 both with post-notification version 1.2.32.

My Steps:
1. copy post-notification folder to wp plugins folder.
2. create a folder named 'post_notification' in wp-content (and coping en_US content into this folder)
3. (not working with or without) chmod _temp dir and the files inside to 777
4. adding a widget to a blog
5. go to option > post notification > test  (test mail is working after adding an email address manually).
6. go to option > post notification > settings (nothing, a blank page, no settings...)
Dieser Beitrag wurde am 14.05.2009, 16:42 von saharusa verändert.
Morty (Administrator) #5
Benutzertitel: Author
Mitglied seit 06/2007 · 928 Beiträge
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Delete the 'post_notification' in wp-content. You only need it if you have your own profiles. It should be working anyway, but there might be a bug when, the dir exists but does not contain any profiles.
saharusa #6
Mitglied seit 05/2009 · 5 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hi again and thanks for helping, when I delete the 'post_notification' in wp-content and than trying to access the settings page i get this:

Settings

Please save own Profiles in: /var/www/html/mywp/wp-content/post_notification/
Otherwise they may be deleted using autoupdate.

and that's it... nothing else, any idea ?
cckborg #7
Mitglied seit 05/2009 · 2 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
I, too, have the same problem with WP 2.7.1 and PN 1.2.32. Like Saharusa, under Settings, I get the message about saving my profiles in .../blog/wp-content/post_notification/ or I'll lose them in autoupdate. Otherwise, the Settings page is blank.

My Steps:
1. Copy post_notification folder to wp-plugins folder.
2. Activate Post Notification plugin.
3. Add PN widget to the blog.
4. Go to Settings > Post Notification > settings (error message only, a blank page, no settings...)

Do I have to create the wp-content/post_notification directory or should the plugin do that automatically?
Is this related to the Settings page being blank?
Carol
saharusa #8
Mitglied seit 05/2009 · 5 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
hopefully Morty will figure it out, I can't find what is the reason the settings page appear empty.
saharusa #9
Mitglied seit 05/2009 · 5 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Found it!

Japanese folder missing some files.... and the plugin is searching every language folder for all files and than use REQUIRE.... delete Jap or change to INCLUDE and have fun :)
cckborg #10
Mitglied seit 05/2009 · 2 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Thanks. Super detective work.

To clarify, do I simply delete the ja-JP folder or do I have to delete the REQUIRE line? Which file would that be in?
Carol
Leo Plaw #11
Benutzertitel: http://leoplaw.com
Mitglied seit 05/2009 · 3 Beiträge · Wohnort: Berlin
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Delete the "ja-JP folder". It works just fine then.  8)

For the the plugin author...


Parse error: syntax error, unexpected '?' in /post-notification/ja-JP/strings.php on line 16
Bisulca #12
Mitglied seit 01/2010 · 1 Beitrag
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
I get the same message with Wordpress 2.9.

Please save own Profiles in: /home/httpd/vhosts/alpines.be/httpdocs/wordpress/wp-content/post_notification/
Otherwise they may be deleted using autoupdate.

I am getting emails, but the subscription doen't work.
Any idea what is wrong?
Morty (Administrator) #13
Benutzertitel: Author
Mitglied seit 06/2007 · 928 Beiträge
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Is this still an issue?
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Gehe zu Forum