Nicht angemeldet. · Kennwort vergessen · Registrierung deaktiviert
Forum: Übersicht Bugs / Fehler RSS
Plugin causes Pages interface to return no pages
rdnovo #1
Mitglied seit 02/2009 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: Plugin causes Pages interface to return no pages
WordPress 2.7.1

With Post Notification activated (both by itself, or with all my other plugins active) when I go to Edit Pages I see the admin interface come up, but even though the text under the title indicates that I have Pages:

All (6) | Published (6)

No pages show up between the table header and footer.  The header and the footer are mashed together because there are no rows returned (or displayed, at least) between them.  See attached png for image.

If I deactivate Post Notification, then the pages show up just fine.

Regardless of whether Post Notification is active, the pages display perfectly well in the front end.

So, not a critical bug, but a curious one, and a pain to edit pages (have to deactivate Post Notification first).

Thanks,

Danny.
Der Autor hat eine Datei an diesen Beitrag angehängt:
wp-271-post-notification-pages.png | Speichern   39,7 kBytes, 354 mal heruntergeladen
Morty (Administrator) #2
Benutzertitel: Author
Mitglied seit 06/2007 · 928 Beiträge
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Probably some problem with php crashing due to some unsupported command. Do you get to the PN-Settings? Any warnings?
rdnovo #3
Mitglied seit 02/2009 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Morty,

No other problems with anything.  I can see all the PN Settings screens, with no errors visible.  It just seems to be some sort of display problem with the Edit Pages admin page in WP.  Edit Posts shows all the posts with no problem.

Could it have something to do with the weird name of the post notification Page?  Or something like that?  I dunno.

Danny.
Morty (Administrator) #4
Benutzertitel: Author
Mitglied seit 06/2007 · 928 Beiträge
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Hmm I cna't reproduce the problem. Can you try to change the "Name of the Post Notification Page" setting. It might be though, that there is some problem with another plugin.
rdnovo #5
Mitglied seit 02/2009 · 3 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Yeah, I realize there may be some other plug-in problem, but I *did* deactivate all the plugins, then reactivated PN, and had the problem.

When I turn off PN, and look at my list of Pages, there is the PN page, which is titled "@@post_notification_header" but clearly that is not the problem, as when PN is deactivated, the listing of Pages shows up just fine.

Currently, my setting for "Name of the Post Notification page:" is "Subscribe by Email".  Do you have any suggestions as to how I should rename it?  I don't see how any of those characters could be troublesome.

I guess I'm stumped, too.

Thanks.  I do enjoy PN.  I'll just keep deactivating it when I need to edit my Pages.
Morty (Administrator) #6
Benutzertitel: Author
Mitglied seit 06/2007 · 928 Beiträge
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
The main problem is, that I am not able to reproduce the problem. Have you got gears installed? (I haven't)
Dieser Beitrag wurde am 25.10.2009, 19:55 von Morty verändert.
fre391 #7
Mitglied seit 10/2009 · 2 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: Have the same problem
I guess its related to the page  '@@post_notification_header'.
As soon as it is created all pages will be hidden in the backend.

The only way out is to deactivate the plugin and delete the above file.
I'm using WPMU 2.8.4.

Any idea ?
Thanks for feedback....
fre391 #8
Mitglied seit 10/2009 · 2 Beiträge
Gruppenmitgliedschaften: Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Betreff: gears
also not installed ;-)
Morty (Administrator) #9
Benutzertitel: Author
Mitglied seit 06/2007 · 928 Beiträge
Gruppenmitgliedschaften: Administratoren, Mitglieder
Profil anzeigen · Link auf diesen Beitrag
Can someone mail me at morty@gmx.net so I can send a test-version to see whether that fixes the issue?
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Gehe zu Forum